What browser version do I need to use?


Return to Frequently Asked Questions

The system supports the following browsers:
  • FireFox 1.5 or above
  • Netscape 7.2 or above
  • Internet Explorer 5.5 sp 2 or above
  • Safari
  • Chome
  • Opera

We also recommend that following items also be installed on your machine: